<!doctype html><html lang=en-US class=gnt__njs data-u-s=anon><head><meta charset=utf-8 /><meta name=viewport content="width=device-width,initial-scale=1,minimum-scale=1"/><meta name=theme-color content=#0098FE /><title>DESTIN EVENTS AND ENTERTAINMENT June 12</title><meta property=og:title content="DESTIN EVENTS AND ENTERTAINMENT June 12"/><link rel=amphtml href=https://amp.srpressgazette.com/amp/7651561002 /><meta property=article:author content="Pam Griffin"/><meta property=article:content_tier content=metered /><meta property=article:opinion content=false /><link rel=dns-prefetch href=//user.srpressgazette.com /><link rel=preconnect href=https://user.srpressgazette.com /><link rel=dns-prefetch href=//content-static.gannett.com /><link rel=dns-prefetch href=//www.gannett-cdn.com /><link rel=dns-prefetch href=//securepubads.g.doubleclick.net /><link rel=preconnect href=https://securepubads.g.doubleclick.net /><link rel=dns-prefetch href=//adservice.google.com /><link rel=preconnect href=https://adservice.google.com /><link rel=dns-prefetch href=//tpc.googlesyndication.com /><link rel=preconnect href=https://tpc.googlesyndication.com /><link rel=dns-prefetch href=//googleads.g.doubleclick.net /><link rel=dns-prefetch href=//s0.2mdn.net /><link rel=dns-prefetch href=//partner.googleadservices.com /><link rel=dns-prefetch href=//www.googletagservices.com /><link rel=preconnect href=https://www.googletagservices.com /><link rel=dns-prefetch href=//static.adsafeprotected.com /><link rel=preconnect href=https://static.adsafeprotected.com /><link rel=dns-prefetch href=//pixel.adsafeprotected.com /><link rel=preconnect href=https://pixel.adsafeprotected.com crossorigin/><link rel=dns-prefetch href=//c.amazon-adsystem.com /><link rel=preconnect href=//c.amazon-adsystem.com /><link rel=dns-prefetch href=//js-sec.indexww.com /><link rel=preconnect href=https://js-sec.indexww.com /><link rel=dns-prefetch href=//aax.amazon-adsystem.com /><link rel=preconnect href=//aax.amazon-adsystem.com /><link rel=dns-prefetch href=//fastlane.rubiconproject.com /><link rel=preconnect href=https://fastlane.rubiconproject.com /><link rel=dns-prefetch href=//bidder.criteo.com /><link rel=preconnect href=https://bidder.criteo.com /><link rel=dns-prefetch href=//colossusssp.com /><link rel=preconnect href=https://colossusssp.com /><link rel=dns-prefetch href=//gannett-d.openx.net /><link rel=preconnect href=https://gannett-d.openx.net /><link rel=dns-prefetch href=//hbopenbid.pubmatic.com /><link rel=preconnect href=https://hbopenbid.pubmatic.com /><link rel=dns-prefetch href=//ads.pubmatic.com /><link rel=dns-prefetch href=//as-sec.casalemedia.com /><link rel=preconnect href=https://as-sec.casalemedia.com /><link rel=dns-prefetch href=//ib.adnxs.com /><link rel=preconnect href=https://ib.adnxs.com /><link rel=dns-prefetch href=//adserver.adtechus.com /><link rel=preconnect href=https://adserver.adtechus.com /><link rel=dns-prefetch href=//apex.go.sonobi.com /><link rel=preconnect href=https://apex.go.sonobi.com /><link rel=dns-prefetch href=//sofia.trustx.org /><link rel=preconnect href=https://sofia.trustx.org /><link rel=dns-prefetch href=//tlx.3lift.com /><link rel=preconnect href=https://tlx.3lift.com /><link rel=dns-prefetch href=//e.serverbid.com /><link rel=preconnect href=https://e.serverbid.com /><link rel=dns-prefetch href=//confiant-integrations.global.ssl.fastly.net /><link rel=preconnect href=https://confiant-integrations.global.ssl.fastly.net /><link rel=preconnect href=https://s0.2mdn.net /><link rel=preconnect href=https://ads.adaptv.advertising.com /><link rel=preconnect href=https://search.spotxchange.com /><link rel=preconnect href=https://static.adsafeprotected.com /><link rel=preconnect href=https://imasdk.googleapis.com /><link rel=dns-prefetch href=//ads.adaptv.advertising.com /><link rel=dns-prefetch href=//search.spotxchange.com /><link rel=dns-prefetch href=//static.adsafeprotected.com /><link rel=dns-prefetch href=//imasdk.googleapis.com /><link rel=dns-prefetch href=//a.teads.com /><link rel=dns-prefetch href=//a.teads.tv /><link rel=preconnect href=https://a.teads.tv /><link rel=dns-prefetch href=//geolocation.onetrust.com /><link rel=preconnect href=https://geolocation.onetrust.com /><link rel=dns-prefetch href=//atoms.srpressgazette.com /><link rel=dns-prefetch href=//cdn.taboola.com /><link rel=preconnect href=https://cdn.taboola.com /><link rel=dns-prefetch href=//trc.taboola.com /><link rel=preconnect href=https://trc.taboola.com /><link rel=dns-prefetch href=//www.usatodaynetworkservice.com /><link rel=preload as=fetch type=application/json href=https://user.srpressgazette.com/NSPG-GUP/user/ crossorigin=use-credentials /><link rel=preload as=script href=/tangstatic/js/pbjsandwich-q1a2z357c67ab5.min.js /><link rel=preload as=script href=https://c.amazon-adsystem.com/aax2/apstag.js /><link rel=preload as=script href=https://js-sec.indexww.com/ht/p/184808-89514051626416.js /><link rel=preload as=script href=https://static.adsafeprotected.com/iasPET.1.js /><link rel=preload as=script href=https://securepubads.g.doubleclick.net/tag/js/gpt.js /><link rel=preload as=script href=https://confiant-integrations.global.ssl.fastly.net/r5TdgVvkbv-PeaJCKaQfCh5Xsto/gpt_and_prebid_v3l/config.js /><link rel=preload as=script href=/tangstatic/js/main-q1a2z32ea41863.min.js /><link rel=preload as=script href=https://geolocation.onetrust.com/cookieconsentpub/v1/geo/location/gnt.otgc /><link rel=preload as=script href=https://cdn.taboola.com/libtrc/gannett-network/loader.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/controls-a427b147.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/share-4cfe2242.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/tealplayer-0be9f6c1.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-comscore-f1701de9.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-gcianalytics-23c0960c.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-hls-aa645eb8.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-parsely-b3e4ce3e.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/encore-c29e248c.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-ima-ac4c537c.min.js /><link rel=preload as=fetch href="https://hlsmedia.gannett-cdn.com/authoring/video-renditions/50249968-ceef-4160-8e57-b536ece4ca58/3caff065-4b27-4bae-a1e1-c003199e89a6/1080p_30fps,720p_30fps,480p_30fps,master.m3u8?subtitles=7646085002" crossorigin/><link rel=preload as=script href=/gannett-web/apps/teal/dist/vendor/hls/hls.0.14.9.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/vendor/comscore/streamsense-5.1.1.160316.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/vendor/ias/ias-3.5.1.min.js /><link rel=preload as=script href=https://s0.2mdn.net/instream/video/client.js /><link rel=preload as=script href=https://imasdk.googleapis.com/js/sdkloader/ima3.js /><meta name=description content="DESTIN EVENTS AND ENTERTAINMENT June 12"/><meta property=og:description content="DESTIN EVENTS AND ENTERTAINMENT June 12"/><meta property=fb:pages content=10153900374175310 /><meta property=fb:app_id content=2695386287417530 /><link rel=canonical href=https://www.srpressgazette.com/story/entertainment/2021/06/11/destin-events-and-entertainment-june-12/7651561002/ /><meta property=og:url content=https://www.srpressgazette.com/story/entertainment/2021/06/11/destin-events-and-entertainment-june-12/7651561002/ /><meta property=og:site_name content="Santa Rosa Press Gazette"/><meta property=og:image content="https://www.gannett-cdn.com/presto/2021/01/13/NSPG/495fff95-4ecb-4f79-8e52-5e28b5f4b004-log_com_calendar.jpg?crop=297,168,x0,y0&width=297&height=168&format=pjpg&auto=webp"/><meta property=og:image:width content=297 /><meta property=og:image:height content=168 /><meta name=ROBOTS content="NOODP, NOYDIR, max-image-preview:large"/><meta name=google content=notranslate /><meta property=og:type content=article /><script>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</script><style>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</style><meta name=twitter:card content=summary_large_image /><meta name=twitter:image content="https://www.gannett-cdn.com/presto/2021/01/13/NSPG/495fff95-4ecb-4f79-8e52-5e28b5f4b004-log_com_calendar.jpg?crop=297,168,x0,y0&width=297&height=148&format=pjpg&auto=webp"/><meta name=twitter:site content=@srpressgazette /><meta name=twitter:creator content=@srpressgazette /><meta name=twitter:title content="DESTIN EVENTS AND ENTERTAINMENT June 12"/><meta name=twitter:description content="DESTIN EVENTS AND ENTERTAINMENT June 12"/></head><body><svg style=display:none><symbol id=gnt_svg_external viewBox="0 0 18 18"><path d="M12.43 5.5H10.5V4H15v4.5h-1.5V6.55l-4.56 4.56-1.06-1.06 4.55-4.55zm1.07 9v-3.75H15V16H3V4h5.25v1.5H4.5v9h9z"/></symbol><svg id=gnt_svg_share_facebook viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#4460a0)><path d="M10.5932 20.9998C6.291 20.3204 3 16.5743 3 12.055 3 7.054 7.0294 3 12 3s9 4.054 9 9.0549c0 4.5198-3.2914 8.266-7.5943 8.9451v-6.3188h2.097l.3991-2.6175h-2.496v-1.6985c0-.716.3486-1.414 1.4666-1.414h1.1349V6.7227s-1.03-.1769-2.0146-.1769c-2.0558 0-3.3995 1.2536-3.3995 3.523v1.9948H8.3081v2.6175h2.2851v6.3186z"/></svg><symbol id=gnt_svg_share_twitter viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#00aaec)><path d="M21 6.776a7.213 7.213 0 0 1-2.12.596 3.778 3.778 0 0 0 1.623-2.095 7.273 7.273 0 0 1-2.346.918A3.642 3.642 0 0 0 15.462 5c-2.038 0-3.692 1.696-3.692 3.787 0 .296.032.585.095.862-3.069-.158-5.79-1.664-7.612-3.958a3.856 3.856 0 0 0-.5 1.906c0 1.313.652 2.472 1.643 3.152a3.626 3.626 0 0 1-1.673-.473v.047c0 1.835 1.273 3.366 2.963 3.713-.31.089-.636.133-.973.133-.238 0-.47-.023-.695-.067.47 1.504 1.833 2.599 3.45 2.628A7.292 7.292 0 0 1 3 18.3 10.282 10.282 0 0 0 8.66 20c6.794 0 10.508-5.77 10.508-10.774 0-.164-.003-.329-.01-.49A7.58 7.58 0 0 0 21 6.776"/></symbol><symbol id=gnt_svg_share_email viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#626262)><path d="M3 5.88c0-.49.4-.88.9-.88h16.2c.5 0 .9.4.9.88v12.24c0 .49-.4.88-.9.88H3.9a.9.9 0 0 1-.9-.88V5.88zm9 5.21L3 6.74v1.74l9 4.35 9-4.35V6.74l-9 4.35z"/></symbol><symbol id=gnt_svg_shareapi viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#000)><path d="M14 5l6 7-6 7V5zm0 4v6c-1.937-.271-3.937.062-6 1s-3.73 2.271-5 4c.909-3.576 2.242-6.242 4-8s4.091-2.758 7-3z"/></symbol></svg><header class=gnt_n onmousedown=event.stopPropagation() onmouseup=event.stopPropagation()><div class=gnt_n_lg_w><button class=gnt_n_sb data-g-r=base_sb data-t-l=":n|v|c|skip to main content" aria-label="Skip to main content"></button><a class=gnt_n_lg href=/ aria-label="Santa Rosa Press Gazette" data-t-l=:n|v|c|logo><svg id=gnt_svg_lg fill=#303030 class=gnt_n_lg_svg preserveAspectRatio="xMinYMid meet" viewBox="0 0 313.28 38.74"><path d="M0 37.45V.62h15.89c9.01 0 13.52 3.61 13.52 10.82 0 7.29-5.01 10.93-15.03 10.93h-3.7v15.08H0zm10.69-18.48h2.4c3.89 0 5.83-2.57 5.83-7.72 0-4.82-1.94-7.23-5.83-7.23h-2.4v14.95zM51 20.13h-6.75c.23-1.06.44-1.84.62-2.35.25-.74.38-1.4.38-2 0-1.15-.41-1.73-1.24-1.73-.63 0-1.23.76-1.81 2.28a13.41 13.41 0 00-.86 4.82v16.3h-9.85v-27.2l1.92.03c2.27 0 4.91-.24 7.93-.73v4.48c1.6-2.99 3.56-4.48 5.88-4.48 3.17 0 4.75 1.75 4.75 5.23 0 .92-.15 1.97-.46 3.16L51 20.13m22.45 7.37l3.97 1.16c-.42 6.27-4.12 9.41-11.12 9.41-9.07 0-13.6-4.52-13.6-13.57 0-4.39 1.2-7.99 3.62-10.79a11.64 11.64 0 019.25-4.21c7.86 0 11.79 5.07 11.79 15.22H63.01c0 7.12 1.81 10.68 5.42 10.68 3.38 0 5.07-2.01 5.07-6.04 0-.54-.02-1.16-.05-1.86m-10.47-5.83h5.88c0-6.33-.95-9.5-2.86-9.5-1.73 0-2.7 2.35-2.91 7.04l-.11 2.46zm38.72-4.43l-4.78.84c0-4.06-1.89-6.1-5.67-6.1-2.32 0-3.48.95-3.48 2.86 0 1.4 2 2.91 5.99 4.53 6.12 2.5 9.17 5.68 9.17 9.52 0 6.13-3.89 9.2-11.68 9.2-8.24 0-12.36-3.07-12.36-9.2l5.07-1.02a14.3 14.3 0 00-.11 1.67c0 1.58.66 2.96 1.98 4.13s2.88 1.75 4.68 1.75c2.37 0 3.56-1.01 3.56-3.02 0-1.35-1.92-2.84-5.75-4.48-5.77-2.48-8.66-5.67-8.66-9.55a7.59 7.59 0 013.32-6.33c2.21-1.65 5.05-2.47 8.53-2.47 6.19.01 9.58 2.56 10.19 7.67m25.26 0l-4.78.84c0-4.06-1.89-6.1-5.67-6.1-2.32 0-3.48.95-3.48 2.86 0 1.4 2 2.91 5.99 4.53 6.12 2.5 9.17 5.68 9.17 9.52 0 6.13-3.89 9.2-11.68 9.2-8.24 0-12.36-3.07-12.36-9.2l5.07-1.02a14.3 14.3 0 00-.11 1.67c0 1.58.66 2.96 1.98 4.13a6.82 6.82 0 004.68 1.75c2.37 0 3.56-1.01 3.56-3.02 0-1.35-1.92-2.84-5.75-4.48-5.77-2.48-8.66-5.67-8.66-9.55a7.59 7.59 0 013.32-6.33c2.21-1.65 5.05-2.47 8.53-2.47 6.18.01 9.57 2.56 10.19 7.67m31.03.33h15.16v19.89h-3.4l-1.16-2.54a16.06 16.06 0 01-9.42 3.16c-5.45 0-9.68-1.63-12.7-4.9-3.01-3.26-4.52-7.87-4.52-13.8 0-5.77 1.6-10.45 4.79-14.02C149.95 1.79 154.12 0 159.29 0c6.8 0 10.94 3.47 12.41 10.42l-5.02 2.29v-.89l-.08-2c-.34-4.33-2.35-6.5-6.02-6.5-2.7 0-4.54 1.15-5.53 3.45-.99 2.3-1.48 6.59-1.48 12.87 0 5.86.4 9.85 1.2 11.95a4.51 4.51 0 004.57 3.16c2.64 0 3.97-1.47 3.97-4.43v-9.07h-5.32v-3.68zm46.3 18.91a19.3 19.3 0 01-7.04 1.4c-3.38 0-5.47-1.05-6.26-3.16-1.64 2.2-3.99 3.29-7.07 3.29-5.74 0-8.61-2.66-8.61-7.99 0-4.05 2.63-6.89 7.88-8.53 4.82-1.51 7.23-3.33 7.23-5.45 0-2.79-1.39-4.18-4.16-4.18-3.2 0-4.8 1.35-4.8 4.05 0 .85.25 1.96.76 3.35l-4.88-.94a15.7 15.7 0 01-.19-2.37c0-4.32 3.94-6.48 11.82-6.48 7.48 0 11.22 2.02 11.22 6.04v16.51c0 1.69.55 2.54 1.65 2.54.34 0 .85-.19 1.51-.57l.94 2.49zM190.34 21.1a8.17 8.17 0 01-2.13 1.75c-2.03 1.19-3.05 3.18-3.05 5.99 0 3.6.7 5.4 2.1 5.4 2.05 0 3.08-1.78 3.08-5.34v-7.8zm37.32-10.85v3.05l-11.9 21.1h11.9v3.05h-22.72v-3.34l11.87-20.81H206.1v-3.05zm21.69 17.25l3.97 1.16c-.41 6.28-4.12 9.42-11.12 9.42-9.07 0-13.6-4.52-13.6-13.57 0-4.39 1.2-7.99 3.62-10.79a11.65 11.65 0 019.26-4.21c7.86 0 11.79 5.07 11.79 15.22h-14.35c0 7.12 1.81 10.68 5.42 10.68 3.38 0 5.07-2.01 5.07-6.04 0-.55-.02-1.17-.06-1.87m-10.46-5.83h5.88c0-6.33-.95-9.5-2.86-9.5-1.73 0-2.7 2.35-2.91 7.04l-.11 2.46zm32.19-11.34v3.05h-4.37v19.24c0 1.21.39 1.81 1.16 1.81.56 0 .89-.4 1-1.21l2.81.27c-.77 2.84-3.24 4.26-7.39 4.26-4.95 0-7.42-2.1-7.42-6.31V13.38h-3.29v-3.05h3.29v-4.8c3.4-.94 6.68-2.28 9.85-4.05v8.85h4.36zm16.73 0v3.05h-4.37v19.24c0 1.21.39 1.81 1.16 1.81.56 0 .89-.4 1-1.21l2.81.27c-.77 2.84-3.24 4.26-7.39 4.26-4.95 0-7.42-2.1-7.42-6.31V13.38h-3.29v-3.05h3.29v-4.8c3.4-.94 6.68-2.28 9.85-4.05v8.85h4.36zm21.5 17.17l3.97 1.16c-.41 6.28-4.12 9.42-11.12 9.42-9.07 0-13.6-4.52-13.6-13.57 0-4.39 1.2-7.99 3.62-10.79a11.65 11.65 0 019.26-4.21c7.86 0 11.79 5.07 11.79 15.22h-14.35c0 7.12 1.81 10.68 5.42 10.68 3.38 0 5.07-2.01 5.07-6.04 0-.55-.02-1.17-.06-1.87m-10.47-5.83h5.88c0-6.33-.95-9.5-2.86-9.5-1.73 0-2.7 2.35-2.91 7.04l-.11 2.46z"/></svg></a></div><div class="gnt_n_sm gnt_n_sm__ne gnt_n_nc__hbn"><a class="gnt_n_sm_a gnt_n_sm__ne_a" data-u-sr="anon reg" href="https://subscribe.srpressgazette.com/specialoffer?gps-source=CPTILELEFT&itm_campaign=2021JUNEFLASH&itm_medium=ONSITE&onSuccessRedirectURL=https%3A%2F%2Fwww.srpressgazette.com%2Fstory%2Fentertainment%2F2021%2F06%2F11%2Fdestin-events-and-entertainment-june-12%2F7651561002%2F" target=_blank rel=noopener data-t-l=":tiffany tile (left nanobar)|p|c|${n}$1 for 6 Months. Save 98%." elementtiming=nav-submsg></a></div><div class="gnt_n_sm gnt_n_nc__hbn"><a class=gnt_n_sm_a data-u-sr="anon reg" href="https://subscribe.srpressgazette.com/specialoffer?gps-source=CPMASTHEAD&itm_campaign=2021JUNEFLASH&itm_medium=ONSITE&onSuccessRedirectURL=https%3A%2F%2Fwww.srpressgazette.com%2Fstory%2Fentertainment%2F2021%2F06%2F11%2Fdestin-events-and-entertainment-june-12%2F7651561002%2F" target=_blank rel=noopener data-t-l=":tiffany tile (right masthead)|p|c|${m}$1 for 6 Months. Save 98%." elementtiming=nav-submsg></a></div><nav class=gnt_n_mn aria-label="Global navigation"><a class="gnt_n_mn_l gnt_n_mn_l__fi gnt_n_mn_ce" href=/news/ data-t-l=:n|v|c|news elementtiming=nav-item>News</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/sports/ data-t-l=:n|v|c|sports>Sports</a> <a class="gnt_n_mn_l gnt_n_mn_ce gnt_n_mn_l__se" href=/entertainment/ data-t-l=:n|v|c|entertainment>Entertainment</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/lifestyle/ data-t-l=:n|v|c|lifestyle>Lifestyle</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/opinion/ data-t-l=:n|v|c|opinion>Opinion</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=https://www.usatoday.com/ data-t-l=:n|v|c|nation-world>USA TODAY</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=https://www.legacy.com/obituaries/srpressgazette/ data-t-l=:n|v|c|obituaries>Obituaries</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=https://classifieds.gannettclassifieds.com/marketplace/ftw/category/Legals data-t-l=:n|v|c|legals>Legals</a><div class=gnt_n_dd_w data-g-r="nav_ce nav_sh"><button class="gnt_n_dd_bt gnt_n_mn_ce" data-g-r=nav_ab data-g-tn=navgdp data-g-ltn=navgd data-t-l=:m|v|g|caret aria-label="Global Navigation" aria-haspopup=true aria-expanded=false><svg class=gnt_n_dd_bt_svg viewBox="0 0 10 6"><path d="M5 3.35L8.64 0 10 1.4 5 6 0 1.4 1.36 0z"/></svg></button></div><div class=gnt_n_us><div class=gnt_n_se data-g-r=nav_ce><a class="gnt_n_se_a gnt_n_mn_ce" data-g-r=nav_ab data-g-tn=navse href=/search/ data-t-l=:r|r|g|icon title=Search aria-label=Search aria-haspopup=true aria-expanded=false><svg class=gnt_n_se_a_svg viewBox="0 0 24 24"><path d="M15.75 14.33l4.96 4.96-1.42 1.42-4.96-4.96a6.5 6.5 0 1 1 1.41-1.41zM10.5 15a4.5 4.5 0 1 0 0-9 4.5 4.5 0 0 0 0 9z"/></svg></a></div><a class="gnt_n_wt gnt_n_mn_ce" href=/weather/ target=_blank rel="external noopener" aria-label="Weather in Milton" title="Weather in Milton" data-t-l=:n|v|c|weather></a> <a class=gnt_n_us_sb data-u-sr="anon reg" href="https://subscribe.srpressgazette.com/specialoffer?gps-source=CPTOPNAVBAR&itm_campaign=2021JUNEFLASH&itm_medium=ONSITE&onSuccessRedirectURL=https%3A%2F%2Fwww.srpressgazette.com%2Fstory%2Fentertainment%2F2021%2F06%2F11%2Fdestin-events-and-entertainment-june-12%2F7651561002%2F" target=_blank rel=noopener data-t-l=:n|p|c|subscribe elementtiming=nav-subbt>Subscribe</a></div></nav></header><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__hi"><div id=ad-slot-7103-fl-milton-C6734-high_impact-entertainment-1 class="gnt_x_sl gnt_x_hi"></div></aside><div class=gnt_bc></div><div class=gnt_cw_w><a class=gnt_cw_sl data-g-r=base_xbutton href=/entertainment/ data-t-l=:b|v|c|overlay aria-label=Close aria-hidden=true tabindex=-1></a> <a class="gnt_cw_sl gnt_cw_sl__ed" data-g-r=base_xbutton href=/entertainment/ data-t-l=:b|v|c|overlay aria-label=Close aria-hidden=true tabindex=-1></a><main class=gnt_cw><div class=gnt_ar_lbl aria-label=Entertainment data-c-ssts=ENTERTAINMENT></div><article class=gnt_pr><h1 class=gnt_ar_hl elementtiming=ar-headline>DESTIN EVENTS AND ENTERTAINMENT June 12</h1><div class=gnt_ar_by><a href=https://www.nwfdailynews.com/staff/5434366002/pam-griffin/ class="gnt_ar_by_a gnt_ar_by_a__fi">Pam Griffin</a><div class=gnt_ar_pb>The Destin Log</div></div><div class=gnt_ar_dt aria-label="Published 9:09 a.m. ET Jun. 11, 2021"></div><div class=gnt_ss data-g-r=base_sc data-ss-u=https://www.srpressgazette.com/story/entertainment/2021/06/11/destin-events-and-entertainment-june-12/7651561002/ data-ss-t="DESTIN EVENTS AND ENTERTAINMENT June 12" data-ss-d="DESTIN EVENTS AND ENTERTAINMENT June 12"><a class=gnt_ss_a href="https://www.facebook.com/dialog/share?display=popup&app_id=2695386287417530&href=https%3A%2F%2Fwww.srpressgazette.com%2Fstory%2Fentertainment%2F2021%2F06%2F11%2Fdestin-events-and-entertainment-june-12%2F7651561002%2F" data-g-r=base_si data-ss-a=f data-t-l=:h|v|c|facebook aria-label="Share to Facebook" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_facebook /></svg></a><a class=gnt_ss_a href="http://twitter.com/share?url=https%3A%2F%2Fwww.srpressgazette.com%2Fstory%2Fentertainment%2F2021%2F06%2F11%2Fdestin-events-and-entertainment-june-12%2F7651561002%2F&text=DESTIN%20EVENTS%20AND%20ENTERTAINMENT%20June%2012&via=srpressgazette" data-g-r=base_si data-ss-a=t data-t-l=:h|v|c|twitter aria-label="Share to Twitter" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_twitter /></svg></a><a class=gnt_ss_a href="mailto:?subject=DESTIN%20EVENTS%20AND%20ENTERTAINMENT%20June%2012%20-%20from%20Santa%20Rosa%20Press%20Gazette&body=DESTIN%20EVENTS%20AND%20ENTERTAINMENT%20June%2012%0A%0ADESTIN%20EVENTS%20AND%20ENTERTAINMENT%20June%2012%0A%0ACheck%20out%20this%20story%20on%20srpressgazette.com%3A%20https%3A%2F%2Fwww.srpressgazette.com%2Fstory%2Fentertainment%2F2021%2F06%2F11%2Fdestin-events-and-entertainment-june-12%2F7651561002%2F" data-t-l=:h|v|c|email aria-label="Share by email"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_email /></svg></a><button class="gnt_ss_a gnt_ss_a__sa" data-g-r=base_si data-ss-a=s data-t-l=:h|v|c|shareapi aria-label="Share natively"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_shareapi /></svg></button></div><aside class="gnt_em gnt_em_vp__tavp" aria-label="Video - Broadway: Jeff Daniels returns, latest on 'Hamilton,' 'Wicked,' more"><div class="" data-g-r=vp_tp data-c-vt=teal data-t-pl=teal-automatedvideoplayer><div class="gnt_em_vp_a gnt_em_vp__tavp_a" data-g-r="vp_ap vp_tg" data-c-vpattrs="{&#34;muted&#34;:true,&#34;bContent&#34;:false,&#34;an&#34;:&#34;fl-milton-C6734&#34;,&#34;pn&#34;:&#34;Santa Rosa Press Gazette&#34;,&#34;vidNum&#34;:1,&#34;avp&#34;:true}" data-c-vpdata="{&#34;adsEnabled&#34;:true,&#34;awsPath&#34;:&#34;entertainment&#34;,&#34;byline&#34;:&#34;Entertain This!&#34;,&#34;canonicalURL&#34;:&#34;&#34;,&#34;contentSourceCode&#34;:&#34;USAT&#34;,&#34;createDate&#34;:&#34;2021-06-10T22:26:23Z&#34;,&#34;credit&#34;:&#34;Entertain This!, USA TODAY&#34;,&#34;duration&#34;:72000,&#34;headline&#34;:&#34;Which stars will return to Broadway once shows like 'To Kill a Mockingbird' reopen?&#34;,&#34;hlsURL&#34;:&#34;https://hlsmedia.gannett-cdn.com/authoring/video-renditions/50249968-ceef-4160-8e57-b536ece4ca58/3caff065-4b27-4bae-a1e1-c003199e89a6/1080p_30fps,720p_30fps,480p_30fps,master.m3u8?subtitles=7646085002&#34;,&#34;id&#34;:&#34;7646085002&#34;,&#34;image&#34;:{&#34;url&#34;:&#34;https://www.gannett-cdn.com/presto/2021/06/10/USAT/7b2fa64e-bc96-4f61-ac24-828d52a8ba65-ET_20210610_427_BWAY_FINAL.jpg&#34;,&#34;opto&#34;:true},&#34;initialPublishDate&#34;:&#34;2021-06-10T22:26:23Z&#34;,&#34;keywords&#34;:&#34;Entertain This!,Video Syndication - OTT Platforms,Video Syndication - USAT,Overall Positive,To Kill a Mockingbird (book),Jeff Daniels,Lin-Manuel Miranda,Hamilton (musical),'Wicked' (stage musical),'Chicago',The Lion King (stage musical),Tony Awards,Broadway Theatre,New York City&#34;,&#34;mp4URL&#34;:&#34;https://downloadmedia.gannett-cdn.com/authoring/video-renditions/50249968-ceef-4160-8e57-b536ece4ca58/3caff065-4b27-4bae-a1e1-c003199e89a6/1080p_30fps.mp4&#34;,&#34;origin&#34;:&#34;USA TODAY&#34;,&#34;pageURL&#34;:{&#34;long&#34;:&#34;https://www.usatoday.com/videos/entertainment/entertainthis/2021/06/10/which-stars-return-broadway-once-shows-like-kill-mockingbird-reopen/7646085002/&#34;},&#34;promoBrief&#34;:&#34;Jeff Daniels and Celia Keenan-Bolger will reprise their roles in \&#34;To Kill a Mockingbird,\&#34; plus other news on Broadway's reopening.&#34;,&#34;propertyName&#34;:&#34;USATODAY&#34;,&#34;publishDate&#34;:&#34;2021-06-10T22:26:23Z&#34;,&#34;series&#34;:&#34;&#34;,&#34;ssts&#34;:{&#34;section&#34;:&#34;entertainment&#34;,&#34;subsection&#34;:&#34;entertainthis&#34;,&#34;topic&#34;:&#34;&#34;,&#34;subtopic&#34;:&#34;&#34;},&#34;tags&#34;:[{&#34;id&#34;:&#34;f0b69399-5e0d-49f5-bb4d-d8d060dd4167&#34;,&#34;name&#34;:&#34;Entertain This!&#34;},{&#34;id&#34;:&#34;16fe9f9b-4247-4e2e-a73c-9fac5b14d01b&#34;,&#34;name&#34;:&#34;Video Syndication - OTT Platforms&#34;},{&#34;id&#34;:&#34;6f55135f-3b5e-490d-8a52-a3b8e1f11ee7&#34;,&#34;name&#34;:&#34;Video Syndication - USAT&#34;},{&#34;id&#34;:&#34;7095bb07-b172-434b-a4eb-8856263ad949&#34;,&#34;name&#34;:&#34;Overall Positive&#34;},{&#34;id&#34;:&#34;f9e38e54-8d15-4b1f-90cd-17303fd5d93c&#34;,&#34;name&#34;:&#34;To Kill a Mockingbird (book)&#34;},{&#34;id&#34;:&#34;35d09d12-801a-4198-b761-8078d2e58ac5&#34;,&#34;name&#34;:&#34;Jeff Daniels&#34;},{&#34;id&#34;:&#34;1217b7ab-6118-418f-8932-8cf4695adb0c&#34;,&#34;name&#34;:&#34;Lin-Manuel Miranda&#34;},{&#34;id&#34;:&#34;606c00c7-d358-4f8f-bcc8-6c5b882f9682&#34;,&#34;name&#34;:&#34;Hamilton (musical)&#34;},{&#34;id&#34;:&#34;16d5f5d1-d836-4430-b956-630146b19b70&#34;,&#34;name&#34;:&#34;'Wicked' (stage musical)&#34;},{&#34;id&#34;:&#34;422fc668-f40c-4586-b214-98ffb067b3dc&#34;,&#34;name&#34;:&#34;'Chicago'&#34;},{&#34;id&#34;:&#34;19a36a84-30b9-4d23-93b6-bc076e75721d&#34;,&#34;name&#34;:&#34;The Lion King (stage musical)&#34;},{&#34;id&#34;:&#34;122e7bc0-2179-4e2d-87b8-fe11719c7f87&#34;,&#34;name&#34;:&#34;Tony Awards&#34;},{&#34;id&#34;:&#34;02265554-ace0-406f-82f3-cbbf1842f0d5&#34;,&#34;name&#34;:&#34;Broadway Theatre&#34;},{&#34;id&#34;:&#34;92ac9d05-f7b6-4498-b146-0cb604868641&#34;,&#34;name&#34;:&#34;New York City&#34;}],&#34;title&#34;:&#34;Broadway: Jeff Daniels returns, latest on 'Hamilton,' 'Wicked,' more&#34;,&#34;url&#34;:&#34;/videos/entertainment/entertainthis/2021/06/10/which-stars-return-broadway-once-shows-like-kill-mockingbird-reopen/7646085002/&#34;}"></div><button class=gnt_em_vp_db aria-label="Close autoplay video player"><svg class=gnt_em_vp_db_svg viewBox="0 0 16 16"><path d="M9 7.625L13.125 3.5 14.5 4.875 10.375 9l4.125 4.125-1.375 1.375L9 10.375 4.875 14.5 3.5 13.125 7.625 9 3.5 4.875 4.875 3.5 9 7.625z"/></svg></button><div class=teal-video-wrap><video poster="https://www.gannett-cdn.com/presto/2021/06/10/USAT/7b2fa64e-bc96-4f61-ac24-828d52a8ba65-ET_20210610_427_BWAY_FINAL.jpg?width=660&height=371&fit=crop&format=pjpg&auto=webp" title="Broadway: Jeff Daniels returns, latest on 'Hamilton,' 'Wicked,' more" muted playsinline elementtiming=avp-video></video></div></div></aside><div class=gnt_ar_b><figure class="gnt_em gnt_em__fp gnt_em_img"><img class=gnt_em_img_i style=height:168px src="https://www.gannett-cdn.com/presto/2021/01/13/NSPG/495fff95-4ecb-4f79-8e52-5e28b5f4b004-log_com_calendar.jpg?width=299&height=168&fit=crop&format=pjpg&auto=webp" elementtiming=ar-lead-image decoding=async alt=Events /><div class="gnt_em_img_ccw gnt_em_img_ccw__cap gnt_em_img_ccw__crd" data-c-caption=Events data-c-credit="[CONTRIBUTED PHOTO]"></div></figure><p class=gnt_ar_b_p><em>Please send your events, meetings, etc., to PGriffin1@gannett.com at least 2 weeks in advance.</em></p><p class=gnt_ar_b_p>Destin City Hall</p><p class=gnt_ar_b_p>All city meetings are being held at the City Hall Annex, 4100 Indian Bayou Trail, until further notice. All meetings are subject to change or cancellation. To virtually view the meeting, https://www.cityofdestin.com/. To view/stream is www.youtube.com/CityofDestin.</p><p class=gnt_ar_b_p>• City Council Budget Workshop, 5:30 p.m. June 14</p><p class=gnt_ar_b_p>• Town Center CRA-AC, 5:30 p.m. June 16</p><p class=gnt_ar_b_p>• City Council, 6 p.m. June 21</p><p class=gnt_ar_b_p>• Special Magistrate Hearing, 5:30 p.m. June 22, City Hall</p><p class=gnt_ar_b_p>• Parks & Recreation, 4 p.m. June 22, City Hall Annex</p><p class=gnt_ar_b_p>• Local Planning Agency, 5:30 p.m. June 24</p><p class=gnt_ar_b_p>Summer at HarborWalk Village</p><p class=gnt_ar_b_p>Monday: Dance to your own beat with a silent disco experience in front of the main stage from 7-10 p.m. Sanitized headphones provided.</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-fl-milton-C6734-native-article_link-entertainment-2 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>Tuesday: Carnival comes to HarborWalk Village with live music on the main stage at 6:30 p.m. and the Fat Tuesday Parade at 8:30 p.m. Catch beads as the floats roll through the Village. Want to celebrate on a float with you and your krewe or promote your business? Email events@harborwalkvillage.com or call 850-424-0600.</p><p class=gnt_ar_b_p>Thursday: All American Thursday is from 6:30 – 9 p.m. Celebrate the USA with a one-of-a-kind vintage airshow, hero salute, live entertainment, fireworks and a fire spinning show with Hero Salute and Vintage Air Show 6:30 p m. and fireworks at 9 p.m.</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-fl-milton-C6734-native-article_link-entertainment-3 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>Saturday: Rock along the docks and under the stars to a free live concert from 7-9 p.m. </p><p class=gnt_ar_b_p>Young Frankenstein</p><p class=gnt_ar_b_p>Stage Crafters presents the Mel Brooks musical, Young Frankenstein, June 12-13 at the Fort Walton Beach Civic Auditorium, 109 Miracle Strip Parkway SW. For Friday and Saturday performances, doors open at 7 p.m., and the show starts at 7:30 p.m. For Sunday matinee performances,  doors open at 1:30 p.m., and the show starts at 2 p.m. General Admission tickets are $30 and can be purchased at www.StageCraftersFWB.com or at the door.</p><p class=gnt_ar_b_p>Mattie Kelly Arts Center</p><p class=gnt_ar_b_p>Highway 98 Country welcomes live country music at Hot Country Night featuring Parmalee June 12 at the Mattie Kelly Arts Center Amphitheater in Niceville. Doors open at 6 p.m. Duchess performs prior to Parmalee taking the stage. Tickets are $20. Call the Box Office for tickets at 729-6000 or visit https://mattiekellyartscenter.org/.</p><aside class="gnt_em gnt_em_anc" id=gnt_atomsnc data-g-r=lazy data-gl-method=loadAnc aria-label="Newsletter signup form"></aside><p class=gnt_ar_b_p>• Jesus Christ Superstar is the 2021 Summer Musical. This year's show will be Jesus Christ Superstar at 7:30 p.m. July 21-24 and 2 p.m. July 25 on Mainstage.</p><p class=gnt_ar_b_p>North Beach Social Wine Mixer</p><p class=gnt_ar_b_p>Celebrate National Rosé Day on the beach with The North Beach Social Wine Mixer all day June 12 at 24200 Hwy. 331 South in Santa Rosa Beach. No helicopters, but plenty of wine from Hey Mama Wines, like $6 rosé and frosé. There will be live music by Mark & Krissa from 12-3 p.m. and DJ Michael Disciple from 5-9 p.m.</p><p class=gnt_ar_b_p>Tailgates Down Concerts</p><p class=gnt_ar_b_p>The Emerald Coast Parrothead Club will host "Tailgates Down" Phriends All Around on June 12 at Mattie Kelly Cultural Arts Village, 4323 Commons Drive W in Destin. Gates open at 9:30 a.m. for tailgating and music from 11 a.m. to 8 p.m. The concert series benefits Fresh Start for Children & Families. Local musicians Jeff and the Camaros, Brent Burns, trop rock artist Mike Nash and nationally renowned Buffett tribute band Gary Roland and the Landsharks will play. Tickets available through Eventbrite are $25 in advance, $30 day of show at the gate.</p><p class=gnt_ar_b_p>Sunday Cinema</p><p class=gnt_ar_b_p>Grab a lawn chair or blanket for the free movie “Croods A New Age,” a featured film on the big screen. at 8 p.m. June 13 on the Events Plaza Lawn at Baytowne Wharf.</p><p class=gnt_ar_b_p>June 20: Secret Life of Pets 2</p><p class=gnt_ar_b_p>June 27: Moana</p><p class=gnt_ar_b_p>July 11: Hotel Transylvania 3: Summer Vacation</p><p class=gnt_ar_b_p>July 18: Pete's Dragon</p><p class=gnt_ar_b_p>July 25: Sing</p><p class=gnt_ar_b_p>Flag Retirement Ceremony</p><p class=gnt_ar_b_p>Davis-Sikes American Legion Post 296, 311 Main Street in Destin, will conduct a flag retirement ceremony in observance of Flag Day. The public is welcome to gather at noon June 13 behind the post.  Bring lawn chairs.</p><p class=gnt_ar_b_p>Baytowne LIVE Music</p><p class=gnt_ar_b_p>The Village of Baytowne Wharf presents Baytowne LIVE on Adventure Lane from 7-9:30 p.m. Schedule includes Steve Hall June 15, 17 and 29; Jarred McConnell June 11; Bobby Cutshaw June 18; and Ken & Andi Johnson June 25.</p><p class=gnt_ar_b_p>Wednesday Night Concert Series</p><p class=gnt_ar_b_p>Enjoy free live entertainment with Will Thompson Band from 7-9 p.m. June 16 on the Events Plaza stage at The Village of Baytowne Wharf.</p><p class=gnt_ar_b_p>June 23: Luke Langford</p><p class=gnt_ar_b_p>June 30: Dion Jones & The Neon Tears</p><p class=gnt_ar_b_p>July 7: Boukou Groove</p><p class=gnt_ar_b_p>July 14: Forrest Williams Band</p><p class=gnt_ar_b_p>July 21: Six Piece Suits</p><p class=gnt_ar_b_p>July 28: Rust & Gold</p><p class=gnt_ar_b_p>Aug. 4: Dion Jones & The Neon Tears</p><p class=gnt_ar_b_p>Aug. 11: Casey Kearney</p><p class=gnt_ar_b_p>Aug. 18: The HooDoos</p><p class=gnt_ar_b_p>Aug. 25: Big Al & The Heavyweight</p><p class=gnt_ar_b_p>Concerts in the Village</p><p class=gnt_ar_b_p>Petty Hearts, Tom Petty Tribute, performs at 7 p.m. June 17 at Mattie Kelly Arts Foundation’s Dugas Stage. Admission is $15/adults, $10/active-duty military, and children (12 and under) and MKAF members are free. Purchase tickets online at Eventbrite. Gates open at 6 p.m</p><p class=gnt_ar_b_p>: • June 24: Air National Guard Band of the South</p><p class=gnt_ar_b_p>Rosemary Beach Moonlight & Movies</p><p class=gnt_ar_b_p>Bring blankets and lawn chairs for a movie night under the stars in Rosemary Beach June 17 with "COCO" on the Western Green. Balloon art starts at 6 p.m. and movie at 8:15 p.m. Enjoy popcorn and hot dogs on the beach from DogManDu.  </p><p class=gnt_ar_b_p>• June 24: Onward</p><p class=gnt_ar_b_p>• July 1: The Secret Life of Pets 2</p><p class=gnt_ar_b_p>• July 8: Toy Story 4</p><p class=gnt_ar_b_p>• July 15 Moana</p><p class=gnt_ar_b_p>• July 22: Sonic the Hedgehog</p><p class=gnt_ar_b_p>• Aug. 5: Tom and Jerry</p><p class=gnt_ar_b_p>• Aug. 12: Trolls World Tour</p><p class=gnt_ar_b_p>Blood Drive</p><p class=gnt_ar_b_p>The Market Shops will host a blood drive with the OneBlood Big Red Bus June 18 from 10 a.m. to 4 p.m. The donation vehicle will be located in the parking lot adjacent to Highway 98.</p><p class=gnt_ar_b_p>Summer Pop</p><p class=gnt_ar_b_p>The Emerald Coast Theatre Company presents  Comedy Night! Side-splitting comedy by a line-up of regional comedians during an evening hosted by Northwest Florida’s funniest, Jason Hedden.June 18 at ECTC’s performance space, 560 Grand Boulevard, upstairs, in the Grand Boulevard Town Center in Miramar Beach. Tickets to each event fundraiser are $30/person. Purchase a Summer Pop pass including all four events for $100. Purchase tickets and packages at www.emeraldcoasttheatre.org.</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-fl-milton-C6734-native-article_link-entertainment-4 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>• July 17 – Jordan and Michelle’s “Back to Broadway” show, a fun-filled, high-energy tribute to the Broadway music of today and yesterday.</p><p class=gnt_ar_b_p>• July 24 – Frank & Friends with Peter Lake. Enjoy tunes from Frank Sinatra, Giacomo Puccini, Andrew Lloyd Webber and many more favorites.</p><p class=gnt_ar_b_p>Food Truck Fest Destin</p><p class=gnt_ar_b_p>Orange Beach Breeze brings the Food Truck Fest from 11 a.m. to 8 p.m. June 20 at Mattie Kelly Cultural Arts Village in Destin. The fest will feature many food trucks in the Panhandle, vendors exhibiting and selling gifts, crafts, jewelry, personal care products and more. This is a family-friendly event. Entry fee is $5 with 12 and under free. Visit www.foodtruckfestdestin.com for more information.</p><p class=gnt_ar_b_p>Movies & S'mores Series</p><p class=gnt_ar_b_p>The free Movies & S'mores series will be at 5 p.m. June 24 in Camp Helen State Park Recreation Hall with food and fun. Seating will be provided. Programs begin at 6:30 p.m. with an interpretive table of activities, a merchandise table, prepackaged smores around the bonfire and a souvenir cup. Movie, “Moana"  begins. at sunset. Donations are accepted and will go directly to the Friends of Camp Helen State Park to be used to benefit the parks resource management, projects and interpretative programs.</p><p class=gnt_ar_b_p>• July 3: The Lion King (2019)</p><p class=gnt_ar_b_p>• July 22: Onward with a special treasure hunt/guided tour throughout the park</p><p class=gnt_ar_b_p>ACT Workshops</p><p class=gnt_ar_b_p>Workshops to assist students in Okaloosa, Escambia and Santa Rosa County high schools who will be taking the  July 17 ACT tests will be held in Gulf Breeze.The workshop will be from 9 a.m. to noon July 12, 13, 14 and 15. Registrations must be postmarked by June 28. All materials, snacks and drinks are furnished. Students will need to bring calculators. If you have any questions, email Amhart1966@aol.com or call  615-585-2401.</p><p class=gnt_ar_b_p>Let Freedom Ring</p><p class=gnt_ar_b_p>HarborWalk Village’s 4th of July celebration, Let Freedom Ring, begins at 7 p.m. July 2 with The Two Hoo Doos. The Miles Band performs July 3 at 7 p.m. and The Manly Hero July 4 at 7 p.m.</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-fl-milton-C6734-native-article_link-entertainment-5 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>Fireworks and fire spinning by Autumn Lyfe begin at 9 p.m. Sunday. Om-site parking $10.</p><p class=gnt_ar_b_p>Smoke on the Coast</p><p class=gnt_ar_b_p>Destin Commons will host 15 local non-profit organizations at the 10th annual Smoke on the Coast BBQ & Fireworks Festival from 5-10 p. m. July 3. Each non-profit organization teams up with a restaurant or BBQ aficionado. Cast your vote for $1 for your favorite BBQ team, support their mission, and enjoy a day of family fun.</p><p class=gnt_ar_b_p>Red, White & Baytowne</p><p class=gnt_ar_b_p>The Red, White, and Baytowne celebration takes place from 7-9:15 p.m. July 4 with music from Donovan Keith on the Events Plaza Stage at Baytowne Wharf. A fireworks display will light up the night sky at 9:15 p.m. The Village will also host kids activities including kids crafts, face painting, and balloon sculpting.</p><p class=gnt_ar_b_p>Hydroflight Monday</p><p class=gnt_ar_b_p>Enjoy shows from fly-board extraordinaire Ben Merrell over the lagoon at The Village of Baytowne Wharf at 6:30 and 8:30 p.m. Mondays through Aug. 2.</p><p class=gnt_ar_b_p>Boomin' Tuesday</p><p class=gnt_ar_b_p>Turn your eyes on the sky at Baytowne Wharf and watch as the sky lights up with a fireworks show over the Lagoon at 9:15 p.m. Tuesdays through Aug. 3. Also, a DJ Dance Party with DJ Mike Whitty begins at 7 p.m. in the Events Plaza.</p><p class=gnt_ar_b_p>Magical Thursday</p><p class=gnt_ar_b_p>Magic, music, and mayhem with Baytowne Wharf’s featured pirate Captain Davy takes you on an adventure with two magic shows at 7 and 8 p.m. Thursdays May 20-Aug. 5.</p><p class=gnt_ar_b_p>Destin Woman's Club</p><p class=gnt_ar_b_p>The Annual Fashion Show held by the Destin Woman's Club has been cancelled this year due to the Covid virus. The Fashion Show for 2021 has been scheduled for Nov. 5.  As their major fundraiser, net proceeds go toward the Club's Family Assistance Fund designed to help local families and a local charity.</p><p class=gnt_ar_b_p>RECURRING EVENTS</p><p class=gnt_ar_b_p>Destin Community Center</p><p class=gnt_ar_b_p>All activities are at the Destin Community Center, unless noted. Call 654-5184 or email recreation@cityofdestin.comfor information and to register. Persons with disabilities who require assistance are asked to notify the center 48 hours in advance.</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-fl-milton-C6734-native-article_link-entertainment-6 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>Pickleball: Sessions are Mondays from 12:30-3:30 p.m. Wednesdays from 1-2 p.m. and Fridays from 10:30 a.m. until 1:30 p.m. Fee is $3/session. Racquets and balls are available, just bring your gym shoes.</p><p class=gnt_ar_b_p>Table Tennis: Play from 10 a.m. to 1 p.m. Mondays, Wednesdays and Fridays. Paddles and balls provided. Fee is $2/resident and $3/non-resident.</p><p class=gnt_ar_b_p>Senior Programs</p><p class=gnt_ar_b_p>All activities are at the Destin Community Center, unless noted. Call 654-5184 or email recreation@cityofdestin.com for information and to register. Persons with disabilities who require assistance are asked to notify the center 48 hours in advance. </p><p class=gnt_ar_b_p>— Destin Senior Membership: Join the Destin Seniors to enjoy multiple festivities including the senior lunch bunch, potluck, casino trips, cruises, bingo, chair exercise, knitting, scrabble, and Mexican dominoes. Members must be a Destin resident.</p><p class=gnt_ar_b_p>— Senior Book Club: The Destin Senior Members meet at 10 a.m. the 2nd Wednesday of the month at the Destin Library, 150 Sibert Ave.</p><p class=gnt_ar_b_p>— Senior Drop-In Hours: The Destin Senior Center at Buck Destin Park, 724 Legion Drive, offers senior drop-in hours from 9 a.m. to noon every Tuesday and Thursday for Seniors (50 years and older) to meet and enjoy each other’s company, participate in games such as Mexican Train Dominoes, Scrabble, cards, etc.</p><p class=gnt_ar_b_p>— Senior Walking Club: The Destin Senior Members walk around the Destin Community Center’s gymnasium from 8-9 a.m. Monday-Friday. All of the miles that you walk will be added to the “team map” as we travel from one region to the next. The team’s miles are reported on the 4th Friday of each month at the Destin Senior Membership’s Potluck.</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-fl-milton-C6734-native-article_link-entertainment-7 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>— Destin Senior Chair Exercise 50+ years: Monday and Wednesday mornings from 10-10:45 a.m. at Buck Destin Park consists of performing light exercises to help improve balance, flexibility, strength, and circulation. Free/residents.</p><p class=gnt_ar_b_p>Book Club</p><p class=gnt_ar_b_p>The Destin Library’s Novel Idea Book Club is open to adults and meets every fourth Thursday of the month at 11:30 a.m. via Microsoft Teams. Club members can submit book recommendations – primarily fiction with the occasional non-fiction title – and the club will vote on which ones to read. Membership is open to everyone; however, you will need an Okaloosa County Public Library card to check-out materials. Members will need an email address and internet access to join the discussion.</p><p class=gnt_ar_b_p>City of Destin Annual Passes</p><p class=gnt_ar_b_p>Full-time residents (within the incorporated city limits) are encouraged to submit their request for a 2021 Annual Pass at https://www.cityofdestin.com/342/Annual-Passes. For those who do not have internet access, beach parking passes are only available at City Hall. Henderson Beach State Park and Joe’s Bayou Boat Ramp passes are available at both City Hall and the Destin Community Center. For questions, call 837-4242.</p><p class=gnt_ar_b_p>Adopt-A-Street</p><p class=gnt_ar_b_p>The City of Destin’s Adopt-A-Street Program allows local families, businesses and community groups to perform a valuable community service by adopting sections of a street to keep clear of litter and debris. Groups who participate in this program will have their name listed on the City’s website and signage installed on their adopted street. For more information, call 837-6869 or email adoptastreet@cityofdestin.com.</p><p class=gnt_ar_b_p>Grand Boulevard Farmers Market</p><p class=gnt_ar_b_p>Grand Boulevard Farmers Market takes place every Friday and Saturday from 9 a.m. to 1 p.m. at Grand Park in the heart of Grand Boulevard in South Walton. Bring your shopping bag and load up on local produce, eggs, jams and pies. Homemade soap, good olive oil, and pickled things are all there for the taking. </p><p class=gnt_ar_b_p>Rosemary Beach Farmers Market</p><p class=gnt_ar_b_p>Come browse the 30A Farmers Market in Rosemary Beach on Sundays from 9 a.m. to 1 p.m. The local farmers market takes place on Sundays year round, and Thursdays throughout the summer months, in North Barrett Square along Scenic 30A.</p></div><div class=gnt_ss data-g-r=base_sc data-ss-u=https://www.srpressgazette.com/story/entertainment/2021/06/11/destin-events-and-entertainment-june-12/7651561002/ data-ss-t="DESTIN EVENTS AND ENTERTAINMENT June 12" data-ss-d="DESTIN EVENTS AND ENTERTAINMENT June 12"><a class=gnt_ss_a href="https://www.facebook.com/dialog/share?display=popup&app_id=2695386287417530&href=https%3A%2F%2Fwww.srpressgazette.com%2Fstory%2Fentertainment%2F2021%2F06%2F11%2Fdestin-events-and-entertainment-june-12%2F7651561002%2F" data-g-r=base_si data-ss-a=f data-t-l=:i|v|c|facebook aria-label="Share to Facebook" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_facebook /></svg></a><a class=gnt_ss_a href="http://twitter.com/share?url=https%3A%2F%2Fwww.srpressgazette.com%2Fstory%2Fentertainment%2F2021%2F06%2F11%2Fdestin-events-and-entertainment-june-12%2F7651561002%2F&text=DESTIN%20EVENTS%20AND%20ENTERTAINMENT%20June%2012&via=srpressgazette" data-g-r=base_si data-ss-a=t data-t-l=:i|v|c|twitter aria-label="Share to Twitter" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_twitter /></svg></a><a class=gnt_ss_a href="mailto:?subject=DESTIN%20EVENTS%20AND%20ENTERTAINMENT%20June%2012%20-%20from%20Santa%20Rosa%20Press%20Gazette&body=DESTIN%20EVENTS%20AND%20ENTERTAINMENT%20June%2012%0A%0ADESTIN%20EVENTS%20AND%20ENTERTAINMENT%20June%2012%0A%0ACheck%20out%20this%20story%20on%20srpressgazette.com%3A%20https%3A%2F%2Fwww.srpressgazette.com%2Fstory%2Fentertainment%2F2021%2F06%2F11%2Fdestin-events-and-entertainment-june-12%2F7651561002%2F" data-t-l=:i|v|c|email aria-label="Share by email"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_email /></svg></a><button class="gnt_ss_a gnt_ss_a__sa" data-g-r=base_si data-ss-a=s data-t-l=:i|v|c|shareapi aria-label="Share natively"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_shareapi /></svg></button></div><div class="gnt_tb gnt_tbb"><div id=gnt_tbw_1></div></div></article><div class=gnt_rr><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__pf"><div id=ad-slot-7103-fl-milton-C6734-poster-entertainment-8 class="gnt_x_sl gnt_x_p"></div></aside><div class="gnt_tb gnt_tbr" data-t-l=":taboola (article rail)|e|taboola click"><div id=gnt_tbw_2></div></div><div class="gnt_m gnt_m_fs"><a href="https://cm.srpressgazette.com/site-feedback/?platform=Tangent-Desktop&url=https%3A%2F%2Fwww.srpressgazette.com%2Fstory%2Fentertainment%2F2021%2F06%2F11%2Fdestin-events-and-entertainment-june-12%2F7651561002%2F&marketName=srpressgazette&cta=Right-Rail" class=gnt_m_fs_a data-t-l=":survey|v|c|notice our new look..." aria-label="Notice our new look? As you get used to things, please let us know what you think!"></a></div><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__st"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-fl-milton-C6734-poster_scroll-entertainment-9 class="gnt_x_sl gnt_x_sl__st gnt_x_p"></div></aside></div><div class=gnt_xbr><a class=gnt_ar_xb data-g-r=base_xbutton href=/entertainment/ data-t-l=:b|v|c|x aria-label=Close></a></div></main></div><footer class=gnt_ft data-g-r="lazy lazy_p" data-gl-type=method data-gl-method=shbd><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__lb"><div id=ad-slot-7103-fl-milton-C6734-leaderboard_btf-entertainment-10 class=gnt_x_lb></div></aside><svg class="gnt_ft_lg gnt__hbd" data-g-r=lazy_c alt="Santa Rosa Press Gazette - Part of the USA Today Network"><use xlink:href=#gnt_svg_lg alt/></svg><div class="gnt_ft_lw gnt__hbd" data-g-r=lazy_c><div class=gnt_ft_ls aria-label=About><a href=http://www.gannett.com/careers/ class=gnt_ft_a data-t-l=:f|v|c|about:careers>Careers</a> <a href=https://cm.srpressgazette.com/accessibility/ class=gnt_ft_a data-t-l=:f|v|c|about:accessibility>Accessibility</a> <a href=https://www.srpressgazette.com/sitemap/ class=gnt_ft_a data-t-l=:f|v|c|about:site-map>Site Map</a> <a href=https://floridapublicnotices.com/ class=gnt_ft_a data-t-l=:f|v|c|about:legals>Legals</a> <a href=https://cm.srpressgazette.com/ethical-conduct/ class=gnt_ft_a data-t-l=:f|v|c|about:our-ethical-principles>Our Ethical Principles</a> <a href=https://cm.srpressgazette.com/terms/ class=gnt_ft_a data-t-l=:f|v|c|about:terms-of-service>Terms of Service</a> <a href=https://cm.srpressgazette.com/privacy/ class=gnt_ft_a data-t-l=:f|v|c|about:privacy-policy>Privacy Policy</a> <a href=https://cm.srpressgazette.com/privacy-policy/ class=gnt_ft_a data-t-l=:f|v|c|about:california-privacy-right>Your California Privacy Rights / Privacy Policy</a><button class="gnt_ft_a gnt_ft_a__bl" data-g-r=base_ottid data-t-l=:f|v|c|about:cookie-policy>Do Not Sell My Info / Cookie Policy</button></div><div class=gnt_ft_ls aria-label=Support><a href=https://help.srpressgazette.com/contact-us class=gnt_ft_a data-t-l=:f|v|c|support:contact-us>Contact Us</a> <a href=https://supportlocal.usatoday.com/ class=gnt_ft_a data-t-l=:f|v|c|support:support-local-businesses>Support Local Business</a> <a href=https://localiq.com/markets/florida/milton/ class=gnt_ft_a data-t-l=:f|v|c|support:advertise-your-business>Advertise Your Business</a> <a href=https://cm.srpressgazette.com/advertising-terms-conditions class=gnt_ft_a data-t-l=:f|v|c|support:advertising-terms-and-conditions>Advertising Terms and Conditions</a> <a href=http://www.verican.us/cod6/nwfdailynews class=gnt_ft_a data-t-l=:f|v|c|support:buy-and-sell>Buy and Sell</a> <a href=https://imagn.com/licensing-reprints/ class=gnt_ft_a data-t-l=:f|v|c|support:licensing-and-reprints>Licensing & Reprints</a> <a href=https://help.srpressgazette.com/ class=gnt_ft_a data-t-l=:f|v|c|support:help-center>Help Center</a> <a href=https://account.srpressgazette.com/ class=gnt_ft_a data-t-l=:f|v|c|support:my-account>My Account</a> <a href="https://gmiiservices.newscyclecloud.com/cgi-bin/cmo_gmi-c-cmdb-fla-01.sh/custservice/web/login.html?siteid=SRP" class=gnt_ft_a data-t-l=:f|v|c|support:my-print-account>My Print Account</a> <a href=https://cm.srpressgazette.com/site-feedback/ class=gnt_ft_a data-t-l=:f|v|c|support:feedback>Give Feedback</a></div><div class=gnt_ft_ls aria-label="Stay Connected"><a href=https://subscribe.srpressgazette.com/ class=gnt_ft_a data-t-l=:f|v|c|stay-connected:subscribe-today>Subscribe Today</a> <a href=https://profile.srpressgazette.com/newsletters/manage class=gnt_ft_a data-t-l=:f|v|c|stay-connected:newsletters>Newsletters</a> <a href=http://www.facebook.com/pages/Santa-Rosa-Press-Gazette/284030690309 class=gnt_ft_a data-t-l=:f|v|c|stay-connected:facebook>Facebook</a> <a href=http://www.twitter.com/srpressgazette class=gnt_ft_a data-t-l=:f|v|c|stay-connected:twitter>Twitter</a></div><div class=gnt_ft_ls aria-label="Our Partners"><a href=/jobs class=gnt_ft_a data-t-l=:f|v|c|our-partners:jobs>Jobs</a> <a href=/section/cars class=gnt_ft_a data-t-l=:f|v|c|our-partners:cars>Cars</a> <a href=/homes class=gnt_ft_a data-t-l=:f|v|c|our-partners:homes>Homes</a> <a href=http://marketplace.srpressgazette.com/classifieds/ class=gnt_ft_a data-t-l=:f|v|c|our-partners:classifieds>Classifieds</a> <a href=https://www.reviewed.com/ class=gnt_ft_a data-t-l=:f|v|c|our-partners:reviewed>Reviewed.com</a> <a href=https://www.10best.com/ class=gnt_ft_a data-t-l=:f|v|c|our-partners:10best>10Best</a> <a href=http://www.reachlocal.com/us/en class=gnt_ft_a data-t-l=:f|v|c|our-partners:reach-local>Reach Local</a></div></div><div class=gnt_ft_cr elementtiming=footer-cr>© 2021 www.srpressgazette.com. All rights reserved.</div></footer><script>if(gnt.luxEnabled&&(LUX={ae:[],al:[]},setTimeout(function(){gnt.addScript('/tangstatic/js/perf-q1a2z3ffa38c70.min.js',!0)},3E3),addEventListener("error",a=>{LUX.ae.push(a)}),"function"===typeof PerformanceObserver))try{LUX.al.po=new PerformanceObserver(a=>{LUX.al.push(...a.getEntries())}),LUX.al.po.observe({type:"longtask",buffered:!0})}catch(a){};</script><script>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</script><script async src=/tangstatic/js/main-q1a2z32ea41863.min.js onerror="document.querySelectorAll('.gnt__hbd').forEach(e=>e.classList.remove('gnt__hbd'))"></script><script type="gnt/tmpl" data-tmpl-key=navgdp><div class="gnt_n_dd_oy gnt_n_dd__sz" data-g-r=nav_oy></div><div class="gnt_n_dd gnt_n_dd__sz" data-g-r="nav_dd nav_te nav_ff" tabindex=0></div>|styles|[data-g-s=nav_ao] .gnt_n_dd_bt_svg{transform:rotate(180deg);background:currentColor;fill:#303030}.gnt_n_dd_oy{display:none;left:0;right:0;height:calc(var(--gnt-vh,100vh) - 100px - var(--gnt-sh,0px))}.gnt_n_dd{overscroll-behavior-y:contain;overflow:auto;overflow-x:hidden;box-sizing:border-box;display:none;width:385px;height:calc(var(--gnt-vh,100vh) - 100px - var(--gnt-sh,0px));margin:0 0 0 -20px;padding:7px 20px 0 32px;border-top:5px solid #0098fe;background:#303030;color:#fff}[data-g-s=nav_ao] .gnt_n_dd__sz{display:block;position:absolute}</script><script type="gnt/tmpl" data-tmpl-key=navse><form class=gnt_n_se_fm data-g-r=nav_dd action=/search/ role=search><input class=gnt_n_se_fm_qr data-g-r=nav_pf name=q placeholder="What can we help you find?" mozactionhint=search enterkeyhint=search aria-label="Search query"/><button class=gnt_n_se_fm_sm data-t-l=${se}:r|r|u| aria-label=Submit><svg class=gnt_n_se_fm_sm_svg viewBox="0 0 18 18"><path d="M12.28 9.76H2V7.74h10.28l-2.23-2.31L11.43 4 16 8.75l-4.57 4.75-1.38-1.43 2.23-2.31z"/></svg></button></form>|styles|.gnt_n_se_fm{display:none;align-items:center;justify-content:center;position:absolute;left:0;right:0;height:180px;padding:0 0 15px;border-top:5px solid #0098fe;background:#303030}[data-g-s~=nav_ao] .gnt_n_se_fm{display:flex}.gnt_n_se_fm_qr{width:492px;height:46px;padding:0 50px 0 0;border-style:solid;border-width:0 0 2px;border-color:#fff;border-radius:0;outline:0;background:0 0;color:#fff;font:700 28px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif}.gnt_n_se_fm_qr::placeholder{opacity:1;color:#fff}.gnt_n_se_fm_qr:-webkit-autofill{box-shadow:inset 0 46px #303030;-webkit-text-fill-color:#fff}.gnt_n_se_fm_sm{width:60px;height:50px;border:0;margin:0 -15px 0 -45px;padding:0;outline-offset:-8px;fill:#fff;background:0 0;cursor:pointer}.gnt_n_se_fm_sm:hover{fill:#e0e0e0}.gnt_n_se_fm_sm_svg{width:42px;height:42px;margin-top:3px;stroke:#303030;stroke-width:.5px}</script><script type="gnt/tmpl" data-tmpl-key=vdscta><div class=gnt_em_vp_sbcta><a class=gnt_em_vp_sbcta_sb data-t-l=":d|d|auto subscribe|${t}" target=_blank rel=noopener href="https://subscribe.srpressgazette.com/specialoffer?gps-source=IUXPLAYEROVERLAY&itm_campaign=subtoturnoff&itm_medium=IUX&itm_source=videoautoplay&itm_content=videoavp&onSuccessRedirectURL=https%3A%2F%2Fwww.srpressgazette.com%2Fstory%2Fentertainment%2F2021%2F06%2F11%2Fdestin-events-and-entertainment-june-12%2F7651561002%2F">Subscribe</a> <a class=gnt_em_vp_sbcta_dt data-t-l=":d|d|auto included|${t}" target=_blank rel=noopener href="https://cm.srpressgazette.com/whats-included-subscribe?itm_campaign=subtoturnoff&itm_medium=IUX&itm_source=videoautoplay&itm_content=videoavp">What's included?</a></div>|styles|.gnt_em_vp_sbcta{display:flex;flex-direction:column;text-align:center;position:absolute;top:25px;z-index:4;width:400px;height:225px;background:#000;color:#fff;font-family:'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif;-webkit-font-smoothing:antialiased;-moz-osx-font-smoothing:grayscale;-webkit-user-select:none;user-select:none}.gnt_em_vp_sbcta::before{content:'Autoplay videos can be distracting. Make them go away.';order:-1;margin:38px 0 0;padding:0 55px;font-size:16px;line-height:20px;font-weight:700}.gnt_em_vp_sbcta::after{content:'Subscribers can turn off autoplay video - and more!';order:-1;margin:6px 0 12px;padding:0 88px;font-size:14px;line-height:16px}.gnt_em_vp_sbcta_sb{width:88px;height:30px;margin:0 156px 9px;border-radius:2px;background:#fff;color:#1665cf;font:700 14px/30px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif;-webkit-font-smoothing:initial;-moz-osx-font-smoothing:initial;text-decoration:none;text-align:center}.gnt_em_vp_sbcta_sb:hover{color:#0a32a0}.gnt_em_vp_sbcta_dt{width:max-content;margin:0 auto;padding:0 2px;outline-offset:1px;color:#fff;font:12px/14px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif}.gnt_em_vp_sbcta_dt:hover{color:#e0e0e0}</script><link rel=preload as=fetch type=application/json crossorigin=use-credentials href=/global-q1a2z3qTxbfWUYNvUNEyMvyqriwsUXnQk.min.json /><link rel=dns-prefetch href=//images.taboola.com /><link rel=preconnect href=https://images.taboola.com /><script type=application/ld+json>[{"@context":"http://schema.org","@type":"NewsArticle","headline":"DESTIN EVENTS AND ENTERTAINMENT June 12","description":"DESTIN EVENTS AND ENTERTAINMENT June 12","url":"https://www.srpressgazette.com/story/entertainment/2021/06/11/destin-events-and-entertainment-june-12/7651561002/","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.srpressgazette.com/story/entertainment/2021/06/11/destin-events-and-entertainment-june-12/7651561002/"},"thumbnailUrl":"https://www.gannett-cdn.com/presto/2021/01/13/NSPG/495fff95-4ecb-4f79-8e52-5e28b5f4b004-log_com_calendar.jpg?crop=168,168,x29,y0&width=150&height=150&format=pjpg&auto=webp","image":{"@type":"ImageObject","url":"https://www.gannett-cdn.com/presto/2021/01/13/NSPG/495fff95-4ecb-4f79-8e52-5e28b5f4b004-log_com_calendar.jpg?crop=297,168,x0,y0&width=297&height=148&format=pjpg&auto=webp","height":800,"width":1600},"datePublished":"2021-06-11T13:09:08Z","dateCreated":"2021-06-11T13:09:08Z","dateModified":"2021-06-11T13:09:08Z","articleSection":"entertainment","publisher":{"@type":"Organization","name":"The Destin Log","logo":{"@type":"ImageObject","url":"https://www.gannett-cdn.com/sites/srpressgazette/images/site-nav-logo@2x.png"}},"author":["Pam Griffin"],"keywords":["access:metered","ssts:entertainment","type:story","tag:Entertainment","tag:Overall Positive"],"isAccessibleForFree":true,"isPartOf":{"@type":["CreativeWork","Product"],"name":"The Destin Log - Unlimited Digital Access","productID":"srpressgazette.com:standard"},"metadata":"{\"id\":\"7651561002\",\"siteCode\":\"NSPG\",\"contentSourceCode\":\"NDES\",\"ssts\":\"entertainment\",\"type\":\"story\"}"},{"@context":"http://schema.org","@type":"ImageObject","url":"https://www.gannett-cdn.com/presto/2021/01/13/NSPG/495fff95-4ecb-4f79-8e52-5e28b5f4b004-log_com_calendar.jpg","caption":"Events","copyrightHolder":"[CONTRIBUTED PHOTO]"}]</script></body></html>